2
\$\begingroup\$

Ever since I joined the SE system, when I am editing an answer or a question I can see how it looks before I hit "submit" or accept the edit.

I have found, this morning, that I have to submit the edit (with possible errors in look or content) to find out if it looks as intended.

Did I hit a switch that I am unaware of, or did the SO/SE mega powers make a change? I tried an edit at Christianity.SE and it worked as before in terms of WISIWYG while editing.

Later that same evening: on a different PC, using Chrome rather than IE or Edge, same issue on my answer to this question, but not on this meta question that I am asking. Odd bug.

\$\endgroup\$
  • 1
    \$\begingroup\$ If memory serves me correctly I had a morning where this sort of thing was happening to me a half-year back or so. (I was copy-pasting things to chat to ask other people if it reproduced for them, and nothing did.) I was not able to reproduce it after a system reboot. =\ \$\endgroup\$ – nitsua60 Oct 30 '17 at 14:08
  • \$\begingroup\$ @nitsua60 I'll check back in an hour and see if it's still doing it. \$\endgroup\$ – KorvinStarmast Oct 30 '17 at 14:10
  • \$\begingroup\$ @nitsua60 I am on a different PC now, using Chrome rather than IE. It's still doing it. \$\endgroup\$ – KorvinStarmast Oct 31 '17 at 2:37
  • \$\begingroup\$ I suspect something on your end, given that we don't have more people complaining about the issue. When you open the browser developer tools (F12 on most broswers), in the network tab, if you reload the page, does anything come up with a 400/500 level status (may be highlighted in red)? \$\endgroup\$ – Oded Oct 31 '17 at 9:48
  • \$\begingroup\$ @ODed No, and what is interesting is that it works fine on this meta question, but not on that particular main site answer that I wrote. That's why I was wondering if I hit a switch of some sort by accident in writing the answer. Is there something in markup that does this? \$\endgroup\$ – KorvinStarmast Oct 31 '17 at 12:28
  • \$\begingroup\$ No, there's nothing in markup that would do it. Could be some JavaScript that's failed (possibly corrupt version cached somewhere) - try a hard refresh of the page (Ctrl + F5 on most browsers) - and see if in the developer tools, in the console there are any errors (usually show up in red). \$\endgroup\$ – Oded Oct 31 '17 at 12:31
  • \$\begingroup\$ @Oded Ok, I just figured out what I did yesterday. I must have clicked on "hide preview" by accident at some point, and it carried over across both browsers for my account. For that answer. I just hit that again, and it works, with "hide preview" as the new choice. Operator Error! Thanks for your patience. \$\endgroup\$ – KorvinStarmast Oct 31 '17 at 12:33
2
\$\begingroup\$

A case of operator error

After some help from @Oded, I found the "show preview" / "hide preview" which I'd never used before. (It's in the lower left under the box full of text that we type into). What I must have done yesterday was hit "hide preview" by accident, and it carried over to my browser on both different PCs' : IE on the one I originally had open when I created the answer, and Chrome on my other PC where I tried to edit it and found once again that I didn't see the preview.

Hide Preview did what it is supposed to do; when I selected "Show Preview" it also did what it was supposed to do.

DOH!

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .