2
\$\begingroup\$

I've been trying to add the RPG Bloggers Network RSS feed to the chat, and just can't make it work. It's a feedburner feed, and we have one of those working for Gnome Stew. I've tried playing with the format - setting it to atom, etc. - and still no love. What is wrong? Is there a specific format it requires that I'm missing?

\$\endgroup\$
  • \$\begingroup\$ Is this working now? If it is, can you status-completed it? If it is no longer relevant, do you mind deleting? \$\endgroup\$ – Oded Jul 18 '13 at 10:01
  • \$\begingroup\$ I don't think it's working (we have several feeds configured and only Gnome Stew have I ever seen work). Still using the feedburner feed balpha made below, and it even has post dates now. feeds.feedburner.com/feedburner/VKtY \$\endgroup\$ – mxyzplk Jul 18 '13 at 12:04
  • \$\begingroup\$ OK. Guess this gets marked with status-declined then... \$\endgroup\$ – Oded Jul 18 '13 at 12:04
  • \$\begingroup\$ Actually, I have one user saying he sees it... I can't see it in Firefox or IE... Is there a "make the feed items area appear"command? \$\endgroup\$ – mxyzplk Jul 18 '13 at 12:14
1
\$\begingroup\$

That feed returns RSS 0.92; chat currently doesn't handle that. The ?format parameter doesn't seem to have any impact – are you sure it should? I haven't found any documentation on that.

You can however use Feedburner to convert the format. I have created a custom feedburner feed using the RPG Bloggers feed as input and converting it to RSS 2.0: http://feeds.feedburner.com/feedburner/VKtY

The chat reads that just fine.

However, it looks like that feed (the original one) doesn't return post dates, which may cause problems.

\$\endgroup\$
  • \$\begingroup\$ format= changes the output type dynamically, compare feeds.feedburner.com/rpgbloggers?format=atom and feeds.feedburner.com/rpgbloggers?format=rss2. \$\endgroup\$ – mxyzplk May 2 '11 at 16:26
  • \$\begingroup\$ @mxyzplk: Those two links have identical content. \$\endgroup\$ – balpha May 2 '11 at 16:43
  • \$\begingroup\$ Hmm, I think you're right in that it's wonky though. I hit format=rss and get a version with atom10 links, I hit with format=atom and I get something more HTMLey... \$\endgroup\$ – mxyzplk May 2 '11 at 17:32
  • \$\begingroup\$ And I just added your feedburner link to The Game Table but I don't think it's working... It just shows the URL instead of resolving to a name and I'm not seeing anything come through yet. Oh well. \$\endgroup\$ – mxyzplk May 2 '11 at 20:13
  • \$\begingroup\$ @mxyzplk: Wait a couple of minutes -- The name is updated when the feed is first queried. \$\endgroup\$ – balpha May 2 '11 at 20:19
  • \$\begingroup\$ Ah, it has come through! Cool. Thanks! \$\endgroup\$ – mxyzplk May 2 '11 at 21:47
  • \$\begingroup\$ It works but ... a little wonky, the dates being Jan 1, 0001 and all... \$\endgroup\$ – C. Ross May 3 '11 at 0:40
  • \$\begingroup\$ doesn't seem to work any more. one burst came through but nothing since. \$\endgroup\$ – mxyzplk May 9 '11 at 1:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .